Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Auto upgrade script V3.x

#1
Information 
One little script to upgrade RrouterBoards automatically.
  • ) fetch file from main router containing latest ROS version number;
  • ) get currently running version number;
  • ) extract minor and major version numbers and compare them;
  • ) if version fetched from main router is newer then download combined package directly from mikrotik.com
  • ) reboot.
At first you should create file containing newest version number on main router.

Codice:
/file print file="latestVer";
/file set latestVer.txt content="3.24";
Now we are ready to run scripts on other routers:
Codice:
#########################################################################

Codice:
# download and upgrade

Codice:
#########################################################################


Codice:
# newest version

Codice:
:local lMajor;

Codice:
:local lMinor;


Codice:
# current version

Codice:
:local vMajor;

Codice:
:local vMinor;


Codice:
:local myVer [/system resource get version];


Codice:
:for i from=0 to=([:len $myVer] - 1) do={  

Codice:
    :if ( [:pick $myVer $i] = ".") do={

Codice:
        :set vMajor [:tonum [:pick $myVer 0 $i]];

Codice:
        :set vMinor [:tonum [:pick $myVer ($i + 1) [:len $myVer]]] ;

Codice:
:if ($vMajor < 3) do={

Codice:
    :log warning "RouterOS version too old ($vMajor.$vMinor),  update script not compatible";

Codice:
} else={


Codice:
#      detect platform (architecture-name is not available in older 3.x versions)

Codice:
      :local platform [/system resource get architecture-name];



Codice:
#      fetch latest version

Codice:
      /tool fetch address="172.16.0.1" src-path="latestVer.txt" user="admin" password="" mode=ftp;

Codice:
      :local lVer [/file get latestVer.txt content];



Codice:
    :for i from=0 to=([:len $lVer] - 1) do={  

Codice:
        :if ( [:pick $lVer $i] = ".") do={

Codice:
            :set lMajor [:tonum [:pick $lVer 0 $i]];

Codice:
            :set lMinor [:tonum [:pick $lVer ($i + 1) [:len $lVer]]] ;

Codice:
        }

Codice:
    }


Codice:
    :if (($vMajor = $lMajor) && ($vMinor < $lMinor)) do={

Codice:
        :local pckgName "routeros-$platform-$lMajor.$lMinor.npk";

Codice:
        /tool fetch address=[:resolve "www.mikrotik.com"] host="www.mikrotik.com" mode=http src-path="download/$pckgName";

Codice:
        /system reboot;

Codice:
    } else={

Codice:
               :log info "Upgrade_script: already latest version";

Codice:
       }

Codice:
}


Add scheduler to run this script, for example once in 24h (or whatever interval you like).
Cita messaggio


Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
Exclamation Script: Notifica sovraccarico CPU hamtarociaoo 1 1'728 10-09-2016, 01:18
Ultimo messaggio: hunte88
Information [Mikrotik] Semi-Automating CPE ROS/Firmware/script updates and setting changes berryberry 0 1'412 17-06-2015, 11:54
Ultimo messaggio: berryberry
Information [Mikrotik] SXT 5HnD Alignment Script berryberry 0 1'740 17-06-2015, 11:47
Ultimo messaggio: berryberry
Information [Mikrotik] Yet Another Alignment Script With LEDs And Sound berryberry 0 2'208 17-06-2015, 11:07
Ultimo messaggio: berryberry
  [Mikrotik] Improved auto upgrade script v3.X berryberry 0 1'291 17-06-2015, 10:53
Ultimo messaggio: berryberry
Information [Mikrotik] Automated Upgrade/Downgrade script V3.9+ berryberry 0 1'287 17-06-2015, 10:51
Ultimo messaggio: berryberry
Information [Mikrotik] Monitor logs, send email alert / run script berryberry 0 1'246 16-06-2015, 10:55
Ultimo messaggio: berryberry
Information [Mikrotik] Resilience /Monitoring -ECMP Failover Script berryberry 0 980 16-06-2015, 09:45
Ultimo messaggio: berryberry
Information [Mikrotik] Resilience/Monitoring- Monitoring Script berryberry 0 865 16-06-2015, 08:56
Ultimo messaggio: berryberry
Information [Mikrotik] Log Parser - Event Trigger Script berryberry 0 1'058 11-06-2015, 09:52
Ultimo messaggio: berryberry

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2019 MyBB Group.