Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Force Disconnect Wireless Stations with Low CCQ

#1
Information 
This script checks all registered stations and forces a disconnect for any station(s) which has a CCQ level less than that specified below (in this example it's set to 70% for TX and for RX).
The idea is that once they are forced to disconnect, the stations will attempt to reassociate with the best available AP, eliminating the 'sticky node' problem.
The only modifications you need to make is to change your minimum allowed CCQ level.
On your APs:

Codice:
/system script
add name="station-check" source="/interface \
  wireless registration-table\r\n:foreach i in=[ /interface wireless registration-table find ap=no] \
  do={\r\n   :if ([get \$i tx-ccq] < \"70\" && [get \$i rx-ccq] < \"70\") do={\r\n           :log warning \
  ([get \$i radio-name] . \" was disconnected due to low CCQ - Tx: \" . [get \$i tx-ccq] . \"% / Rx: \" . \
  [get \$i rx-ccq] . \"%\")\r\n           /interface wireless registration-table remove \$i\r\n           \
  :delay 5s\r\n           }\r\n}"
Remember that non-MikroTik stations will not report back their received CCQ, so the TX-CCQ will always be 0%.

Once you have configured the script, set up a scheduler to run the script everytime you want it to check for low signals. In the example below, the script will run every day at 1 second after midnight!

On your APs:

Codice:
/system scheduler

Codice:
add disabled=no interval=1d name="station-check-schedule" on-event="/system script run \

Codice:
  station-check ;" start-time=00:00:01

Cita messaggio


Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
Information [Mikrotik] Logging Average CCQ and Wireless Clients Stats berryberry 0 908 16-06-2015, 12:15
Ultimo messaggio: berryberry
  Script: Controllo di VPN, Wireless, Hotspot, Utenti Connessi ed Amministratori hamtarociaoo 0 1'432 22-04-2014, 11:24
Ultimo messaggio: hamtarociaoo

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2020 MyBB Group.