Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik ] Improved Netwatch

#1
Information 
This is an improved version of Netwatch that removes false positives. It works by pinging the target IP 5 times. If all 5 time out then the specified action is taken.
Codice:
:local i 0; {:do {:set i ($i + 1)} while (($i < 5) && ([/ping 72.14.207.104 interval=3 count=1]=0))};

Codice:
       :if ($i=5 && [/ip route get [find comment="Default Route"] disabled]=false) do={:log info "Main Gateway down";

Codice:
        /ip route set [find comment="Default Route"] disabled=yes}


In this case it searches for a route labelled "Default Route" and disables it if 5 pings in a row to www.google.com time out. To re-enable on 5 succesfull pings you could have some thing like:

Codice:
:local i 0; {:do {:set i ($i + 1)} while (($i < 5) && ([/ping 72.14.207.104 interval=3 count=1]=1))};

Codice:
      :if ($i=5 && [/ip route get [find comment="Default Route"] disabled]=true) do={:log info "Main Gateway up";

Codice:
      /ip route set [find comment="Default Route"] disabled=no}


ping return number of recieved packets (at last on latest 3.x and щт 4.x). Next do same
Codice:
:if ([/ping 72.14.207.104 interval=3 count=5]=5 && [/ip route get [find comment="Default Route"] disabled]=false) do={

Codice:
           :log info "Main Gateway down"; /ip route set [find comment="Default Route"] disabled=yes}

Cita messaggio


Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
Information [Mikrotik] Netwatch on web berryberry 0 1'625 17-06-2015, 11:40
Ultimo messaggio: berryberry
  [Mikrotik] Improved auto upgrade script v3.X berryberry 0 1'590 17-06-2015, 10:53
Ultimo messaggio: berryberry
Information [Mikrotik] Failover via Netwatch III (English) berryberry 0 1'078 16-06-2015, 10:01
Ultimo messaggio: berryberry
Information [Mikrotik] Improved Netwatch II berryberry 0 945 16-06-2015, 09:54
Ultimo messaggio: berryberry
  Netwatch kikko 31 12'853 03-12-2013, 18:38
Ultimo messaggio: kikko

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2020 MyBB Group.